Jump to content

Correct Redis set up with php-fpm varnish server set up - not working

Recommended Posts

Hi - I am on CWP 7 (NGINX/Apache/PHP-FPM/Varnish) I have enabled redis and memcache toggle for both php and php-fpm selectors (php 8.1). The toggle informtaion shows that redis server will be downloaded and installed. In earlier versions it used to be save and build but in my version it just shows save. After saving, when i go to the domain wordpress which is under php 8.1, and try using redis plugin it is not detecting redis.

It is showing below errors:
Redis is unreachable: Connection refused [tcp://]
Status:    Not enabled
Filesystem:    Writeable
Redis:    Unreachable
Status: Not enabled
Drop-in: Not installed
Disabled: No
PhpRedis: Not loaded
Relay: Not loaded
Predis: 2.1.2
Credis: Not loaded
PHP Version: 8.1.20
Plugin Version: 2.5.0
Redis Version: Unknown
Multisite: No
Metrics: Disabled
Metrics recorded: 0
Filesystem: Writable
WP_REDIS_PLUGIN_PATH: "/home/edgeho83/public_html/blog3/wp-content/plugins/redis-cache"
Drop-ins: []

In SSH shell it is not showing Redis as enabled.

What am i missing.
Modify message
Link to comment
Share on other sites

Hi you need to go to php-fpm selector and rebuild the php by selecting the redis option.

After it is built successful you can confirm it by checking the phpinfo option under php-fpm selector module, i.e. every php versions will have it's own phpinfo option.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...